How to connect the netduino3 to the wifi?

You will need to put the Netduino 3 WiFi into DFU mode and change the product type and then re-flash the firmware:

• Hold down the reset button and connect the Netduino 3 WiFi board to the USB port on your computer.
• Open the Netduino Updater application
• If the Updater states that the board is a WiFi board then simply deploy the updated firmware
• If the board is listed as Netduino 3 or STM Device in DFU Mode then click the Options link, This will open a new dialog box showing the product type and you can change this here. Click the Change link under the dropdown box. This will allow you to select the new product type. Note that this information is written into programmable memory and can only be changed so many times before it is fixed.

@Brijesh_Singh - you may need to follow this advice as well.

Let us know how you get on.


I have tried putting neduino in DFU Mode but I have doubt look at screenshot of device manager which shows yellow mark on STM32 Bootloader.

I think because of this no device is being shown in NetduinoUpdater, Do I need to install any STM32 Driver.

When i accessed the MF deploy through the start menu in windows,It is showing like that

But here the option for setting wifi credentials are locked!How can i enter my wifi credentials

I think,I have a done a mistake @Nevyn
In the Netduino firmware updater,i have selected the Netduino 3 as the device instead of the Netduino 3 Wifi.That’s why the options for giving wifi credentilas in the MF deploy are locked!.
Am i correct?

I think that is correct hence my instructions above on how to attempt to resolve this problem.


All of the drivers necessary should have been installed as part of the NetduinoSDK. Maybe reinstalling will help with this issue.


But in my case,now the netduino updater is not responding!I will tell you clearly!
1:When i open the netduino updater!
2:Chooses the correct board for updating(through the options link)
3:When i closes the device options menu,it is is not responding.The netduino updater automatically closes

So what shall i do to change the firmware. of my board?(Netduino sdk are installed and un-installed for 20 times)

@Nevyn tried un-installed and reinstalled but no luck. Is there any else method to carry out.

Why are you not replying anything?@Nevyn

Use Netduino deploy instead of the mf deploy.

Does this happen when you plug the Netduino into the computer in DFU mode (plug in the board when pressing the reset button)?


With this problem I think that the drivers and SDK are installed correctly as the board is recognised.

Do you have VS 2017 installed on the computer? I think that we would need to run a debug version of the application. This would require cloning the updater application from git and then debugging in VS 2017.


Yes, when I put neduino in DFU mode

what is the link to download Netduino deploy

Yes,this happens only in the DFU mode.

Is there any chance of manual update of firmware in the netduino?


Netduino deploy can be found here.


Thanks @Brad_Patterson. @Nevyn I have updated firmware successfully, still the option for wifi settings are locked Please checkout attachments below.

Locked settings:

I clicked on above update button with default settings in network configuration. Then program closed automatically.
Luckily after restart settings have been opened.

1 Like

No,i have only VS2012 with me.