Community

How to connect the netduino3 to the wifi?

I am using visual studio 2012 express,is there is any scope for me for connecting netduino to the wifi network.

There are a number of options open to you:

  • Use a WiFi shield
  • Use and ESP8266
  • Netduino 3 WiFi

The first two options are reasonably cheap but require some development.

Netduino 3 WiFi boards have this capability built in and will offer the quickest and simplest way to achieve this.

Regards,
Mark

At present ,i have downloaded the .net micro framework deploy for configuring wifi access!
But there is no option to give SSID and Password?
So I am stucked there!(i am owing netduino 3 ,free hardware for the netduino contest in hackster.io)

Is it possible to connect the netduino 3 to the wifi network by simply uploading the code(as that of boards like arduino)

Can you please confirm which board you have:

  • Netduino 3
  • Netduino 3 Ethernet
  • Netduino 3 WiFi

Regards,
Mark

I am using netduino 3

The Netduino 3 does not have networking hardware on the board. In order to connect to a WiFi network you will need to install a WiFi shield or something similar. It will then be necessary to write a driver for the new hardware.

Personally, I would look to purchase a Netduino 3 WiFi as this would be the quickest solution.

Regards,
Mark

1 Like

Sorry, I am owing netduino 3 wifi

OK - so you have the right board for WiFi which is good.

You should be seeing the WiFi SSDI / Password options in MFDeploy - you are looking in the right place by the looks of it.

Using MFDeploy, can you try the Target -> Connection menu item and post the output please.

Regards,
Mark

1 Like

This is the output showing in MF deploy

I think the problem is with my Visual studio 2012.i think so🙂

No option for connection under Target.

So facing same problem faced by @Nekhil_ravi no option for SSID & password

Couple of questions:

  • Have you updated the firmware on the board?
  • Can you let me know the full path to MFDeploy.

Reason for asking is I’m trying to work out why you are both seeing this problem and also why I have additional options in MFDeploy that neither of you are seeing.

Regards,
Mark

Yes,i have updated the firmare in my netduino 3 wifi board using netduino updater(Image is given )

  1. No device is shown when running updater(NetduinoUpdate.exe). I have put device into bootloader mode

  2. Path of MFDeploy is -> E:\Netduino contest\Netduino softwareSetups\MFDeploySP1\MFDeploy
    is it correct or need to put in C derive

I am opening the MF deploy from the downloads of my windows!

I even tried from C derive but same issue persist

You will need to put the Netduino 3 WiFi into DFU mode and change the product type and then re-flash the firmware:

• Hold down the reset button and connect the Netduino 3 WiFi board to the USB port on your computer.
• Open the Netduino Updater application
• If the Updater states that the board is a WiFi board then simply deploy the updated firmware
• If the board is listed as Netduino 3 or STM Device in DFU Mode then click the Options link, This will open a new dialog box showing the product type and you can change this here. Click the Change link under the dropdown box. This will allow you to select the new product type. Note that this information is written into programmable memory and can only be changed so many times before it is fixed.

@Brijesh_Singh - you may need to follow this advice as well.

Let us know how you get on.

Regards,
Mark

I have tried putting neduino in DFU Mode but I have doubt look at screenshot of device manager which shows yellow mark on STM32 Bootloader.

I think because of this no device is being shown in NetduinoUpdater, Do I need to install any STM32 Driver.