Community

Why is the network firmware on these devices so problematic?

I have a total of 5 Netduino 3 WIFIs. Below is the relevant code for making the connection it works on three devices, but would not work on the other two.

I came to the community to find answers and the answer I see most often with network connection problems is that it did not work and then inexplicably it worked.

I tried the answer at


and appear to have bricked that board. It no longer registers with MFDeploy or the development environment! Although NetduinoDeploy does seem to recognize it, but I can not do anything with it. No config, flash, or boot file are shown and clicking choose to manually install ends the program. I am afraid to use this program on my other board,

I found this other approach to use at

Microsoft.SPOT.Net.NetworkInformation.NetworkInterface.GetAllNetworkInterfaces()[0].EnableStaticIP

but that generates the following error on my broken, but not bricked board.
A first chance exception of type ‘System.NullReferenceException’ occurred in Microsoft.SPOT.Net.dll
An unhandled exception of type ‘System.NullReferenceException’ occurred in Microsoft.SPOT.Net.dll

I had thought I would just go buy a couple of new Netduino 3 WIFIs, but are no longer available at either Amazon or Mouser, they have now doubled in price from someplace in China.

I considered upgrading to Meadow, but those do not look to actually be available either and do not appear to have an SD card which I use extensively. The Netduino 3 WIFI is a great product when it works, and very frustrating when they do not.

    private static string GetIPAddress()
    {
        if(Microsoft.SPOT.Net.NetworkInformation.NetworkInterface.GetAllNetworkInterfaces()[0].IsDhcpEnabled)
        {
            while(IPAddress.GetDefaultLocalAddress() == IPAddress.Any)
            {
                Thread.Sleep(100);
            }
        }
        else
        {
            bool NetworkIsAvailable = false;
            do
            {
                Thread.Sleep(100);
                NetworkIsAvailable = System.Net.NetworkInformation.NetworkInterface.GetIsNetworkAvailable();
            } while (!NetworkIsAvailable);
        }

        string ipAddress = Microsoft.SPOT.Net.NetworkInformation.NetworkInterface.GetAllNetworkInterfaces()[0].IPAddress;


        return ipAddress;
    }

I have managed to get both of my dead Netduino3 WIFIs back running. Hopefully someone can help me figure out why or at least this can be helpful for someone else in the future.

I used the program here https://www.st.com/en/development-tools/stsw-stm32080.html
First to wipe the Netduinos clean.
Next I copied the firmware from the working Netduino3 WIFI onto both of my dead devices.

This brought them back to life, but still no WIFI.
I then used .Net Framework Deployment tool to change to a different router. Suddenly I was working again. I was then able to Change back to the original router with no problem.

It seems like I have experienced this before where I could not get the WIFI to work. I tried a different router and things worked. I ma not sure I went back to the first router immediately as I did this time.