System.NullReferenceException on Maple GET Requests

Hi! I’ve been so happy to get to play with Netduinos again - but I’ve been having an incredibly difficult time with networking and Maple. I had a bizarre experience trying to get networking working on my N3E - I tried a static IP, but couldn’t get the example wait loops to work no matter what references etc. I added, so switched to DHCP, and ran into similar issues there; I eventually came up with a hack that allowed me to get the static IP working without any of the missing references (?) and I believe networking is now “working” (I’m somewhat suspicious that my earlier attempts to update network settings actually worked?). I then added Maple based on the README but now I’m getting an error when I try to make GET requests:

Received GET /DoSomething - Invoking GETDoSomething

I’m not sure whether this is a problem with Maple or if my networking isn’t really working?? I pushed my source up in its current state here:

This is for an entry into the Hackster contest so quick feedback would be massively appreciated! :heavy_heart_exclamation:

Answered my own question here:

Hopefully my intense struggle helps someone else one day… :weary::heart:

Good to hear that you are up and running. Hope that the project is going well.


Thanks @Nevyn! :heart:


That’s great news!! Hoping to have some time this 3 day weekend to spend some time on my project again.


1 Like

Cool - ping me if there’s something I can help with! :rocket: