Community

VS 2017 with NETMF 4.3 (existing)

I wonder what can we look forward to concerning Netduino (N3WF in my case).

I do not really need netmf 4.4, and I am ok with the current Netduino firmware, but having existing projects run in VS2017 would be really great.

How do we go about creating a VS2017 extension running against Netduino 4.3.2.3? What is actually that needs to be done there?

1 Like

Hey @Tridy! A couple folks have been working on this, and I think they’re super close to being done. Adrian Stevens and Bryn Lewis have been tag teaming it. You can catch up with them and status on the discord server, where we’ve been chatting about it.

2 Likes

hope they finish ASAP support for .NET Microframework (4.3.x/4.4.x ) for VS2017

1 Like

It works now with VS2019 and 4.3, creating a project, build, deploy.

There is support for 4.4 in VS2019 but we need the 4.4 firmware for Netduino:

Assembly ‘mscorlib’ on the device has version 4.3.1.0, while the program is trying to deploy version 4.4.0.0

Is it something planned or maybe I have missed it and it is available somewhere already?

Do you need network support? If not I have a basic 4.4 port.