Community

Unable to see Meadow board as a com port

Hello

I’ve been trying to get my Meadow board up and running, but when I get to the step in the Getting Started Guide where it says the board should show up as a com port, it doesn’t. The Meadow board shows up in Device manager under Universal Serial Bus devices as ‘Meadow F7 Micro’. Here’s what I’ve tried.

When I update the USB driver with Zadig, the result screen matches the one in the documentation. And running dfu-util --list shows what seems to be the appropriate list of files.

I downloaded the OS and binaries and they downloaded to the Appdata\local\WildernessLabs\Firmware directory.

I flash the OS using Meadow --FlashOS and it ends with
'File downloaded successfully;
‘Transitioning to dfuMANIFEST state’

Then I check Device Manager for the COM port and there the Meadow board is in the Serial Bus Device area. Re-boots don’t seem to change anything.

I’ve tried re-doing things (which may have compounded the issue), but I still get the same result.

Any guidance would be greatly appreciated!

Thanks
Steve B

Hi Steve!

It sounds like the drivers aren’t quite right. With the Meadow running normally (not in BOOT mode), go to Device Manager, right click the “Meadow F7 Micro” and click “Uninstall Device”. In the window that pops up, please check the box for “Delete the driver software for this device”. Finally, click “Uninstall”.

Once the uninstall is complete, unplug the Meadow from all power and USB and plug it back in. This should reset the driver and it should show up as a COM port now.

1 Like

I had the same issue. Following Peter’s instructions fixed my problem.

1 Like