Unable to flash to RC2.1

I’m trying to flash to the latest OS and I’m completely stuck and not able to get this to work on either of the two Meadow boards I have. I’m following the instructions under RC2.1 on the documentation portal, but it’s not working.

When I run meadow flash erase, I get “Selected serial port (COM6) does not exist…”. I run ‘meadow list ports’ as suggested and it says “Found Meadow: COM19”. So I then tried “meadow use port com19” and it shows “Setting port to com19 Done!”. But when I then re-run meadow flash erase, I get “Select serial port (COM19) does not exist”.

I had also tried “meadow flash os -d” and I got “Skipping step to flash Meadow OS. Connecting to Meadow on COM6. Connecting to Meadow on COM19. …”.

Please help as I cannot use either of these boards in the current state.

Hi Kelly,
Can you confirm which Windows OS you are using and what CPU?

When you run meadow --version does it say 0.90.4?
It should be viewable here as a folder too…

Also when you just run meadow flash os does it pick up the latest version from our servers and download it?
You should find several folders in $HOME\AppData\Local\WildernessLabs\Firmware and the latest firmware should be listed there. A folder with the name similar to 0.9.*.*


Windows 11, Intel i9 CPU.
Yes, meadow --version does return v0.90.4
Yes, it did download the latest version and I do see it in %LOCALAPPDATA%\WildernessLabs\Firmware\

@kelly Before running meadow flash erase, did you put the board into boot loader mode?
Namely unplug the board, hold down the boot button and plug the board in while the boot button is held?
There shouldn’t be any lights appearing on the board once it’s plugged in, in boot loader mode.
Then run either meadow flash os or meadow flash erase and let me know what happens.

OK, so I started the board in bootloader mode, but then the device is not seen by the meadow command line utility. meadow list ports returns just “Done!” (no devices found). If I unplug and replug (not in bootloader mode), then “meadow list ports” returns “Found Meadow: COM3”.

@kelly The board needs to be in boot loader mode for the flash to work and as you found out, when in boot loader mode, meadow list ports or meadow use port do not work in that mode. But meadow flash os should work. Boot loader mode is required for low level firmware updates. While normal mode is required for everything else.

Understood, but that doesn’t work either. I put the board in BL mode (no LEDs light up when I plug in), then run meadow flash os and I get “Unable to flash Meadow OS. Done!”. Tried this on two different boards.

Hi @Kelly,

I have a question, when you put your board in Bootloader Mode and Regular Mode, how is it shown in the Device Manager? It should look like this:


If your board appears as Meadow F7 Micro (COMX) in regular mode, right-click on it and select Uninstall Device , and make sure to select Attempt to remove the driver for this device .

More info here to fully update your device if thats the case: How to do a full stack Meadow update – blog.wildernesslabs.co

It shows similar to your illustration.

@kelly Did you follow @Jorge 's suggestions about the full stack Meadow update, from the link he provided?

If you just bought a new version of the board and get the following error when updating:

Flashing OS with C:\Users\Max\AppData\Local\WildernessLabs\Firmware\\Meadow.OS.bin
Unable to flash Meadow OS: Operation not supported or unimplemented on this platform

Then you need to uninstall the device, even though it shows as a “USB Serial Device (COM4)” (for me it never showed the Meadow F7 Micro) in device manager. and re-install with the Zadig tool. Then after updating the driver to WinUSB it worked like a charm,

So, the install guide needs to get updated to also reinstall the driver when the “Universal Serial Bus Device” does not show up. Just bought a board in 9/2023.