PWM type could not be found [SOLVED]

Good morning,

I have a netduino 3 Ethernet and I was test it a little bit by doing some examples.
I setup everything with the getting start page:

Then I testing the PWM function according to an example page:

I use the same references as the example but the type PWM is not being found:

What I’m doing wrong?

Thank you so much for your help.

I’m having a problem

I found the solution for my problem.
If I create the project as a netduino application the PWM type is working good.
But as the getting start page says, to create a console application and even “include” the same using variables, the PWM type wasn’t found.
Maybe there is something wrong in my installation. But if I select a netduino applicaiton it will work just fine.

I hope this help others with this problem.

Thanks for posting this! I had the same problem and this fix also worked for me. :slight_smile:

Still not sure why the LEDs datatype from the script on can’t be resolved. But PWM does pretty much the same thing from what I can tell.

What references do you have included? I’m guessing you’re missing SecretLabs.NetMF.Hardware.Netduino.

Yes, Bryan is right, you can do it if you include all the references that you are “using”.