Newbie; Trouble Getting Started

I was originally running Visual Studio 2017 for another project, so that’s installed (just an fyi in case it may cause interference), but then I got the Netduino 3 with ethernet.

Following the instructions and browsing online lead me to download Visual Studio 2015, and run all the setup steps here:
.NET Micro Framework (.NETMF) v4.3.2 - QFE2 SDK
NETMF Plugin for Visual Studio Visual Studio 2015
Netduino SDK

Once run, I went back to following the ‘Getting Started’ steps ( but when making a new project with micro framework I only have the options of class library, console application and windows application.

Assuming the Console Application would work, I selected it and moved on.

Under references I only have Analyzers and Microsoft.SPOT.Native, and have no idea where to guide the ‘Add Reference’ to in order to find:

I’ve also tried opening the project created by doing all of this, but it says the project is targeting “.NetMicroFramework,Version=v4.4” which is not installed on this machine.

Have I managed to mess up before even starting?
Any help as to where to get these files, how to fix the issues, etc. would be greatly appreciated!

Normally this type of problem is resolved by uninstalling and then reinstalling the various components. Have you tried this?


Hello Billy,

I think you’re missing is to make the project to target to .NetMicroFramework Version=4.3, It’ll prompt you an “are you sure?” dialog, but go ahead and do it. And if you wish to try a project on your netduino, go to the .Net Micro Framework tab in the project’s properties, click the drop-down menu in the Transport section and select “USB”, and the device should be automatically selected if you have it properly connected and installed.

Try that, and see if it works for you.


Thanks for the advice!

I managed to get things started by uninstalling the Netduino SDK and reinstalling, which fixed my computer not seeing the netduino drivers, and by using the NuGet manager to search for anything under Wilderness Labs (I had been looking for Secret Labs and Netduino before since that was part of the file name I was looking for if I remember correctly). This let me find the Netduino Foundation package.

The advice to run framework version 4.3 headed off today’s problem, so now I have a blinking LED. It’s full speed ahead from here on out!

Glad to hear you are up and running.