Netduino wifi deployment

I have been using the Netduino wifi board sense it first was released…The board is fantastic and is very reliable. I can see many commercial uses if the network settings where more user friendly. The perfect setup might be a smart phone app for the network setup. Anyone have any ideas?

USB config for a developer is not a problem but I agree that for devices being deployed in the wild then a soft access point style of configuration would make more sense.


Could you share a resource for configuring the Netduino network settings?

On the windows platform you can change this using MFDeploy.

You should be able to change the network settings using the Target -> Configuration -> Network menu item.


1 Like

Wow I have never been able to get either of my Netduino 3 to really work. Ethernet version tcpip stack did not work and the Wifi version is just a brick. Neither MFDepoly or the windows development environment will recognize it. I have 6 of the N2 Plus and while they have flaws, they work well enough I hope to build a worthwhile product out of them.

I just wish either of my 3s worked at all.

If your device is bricked, have you tried the Netduino Updater on a PC, or the Mac Deploy Tool on Mac? They may be able to unbrick your device. Both of them use DFU to update, rather and MFUSB, so if TinyBooter is corrupted, you can still flash.

Also, we’re working on some network stack fixes for the N3E and N3WiFi.

Hi Bryan,

Thanks for getting back to me. Yes I have! I think the problem is hardware related at the USB port its self, but I cannot know for sure.

I have loved working with the 2 Plus for the last couple of years, but I have no confidence in the 3s at this point.

It is good to know that someone has picked back up Netduino and is working to fix the network issues in the 3s.

USB port on the actual device? Have you tried a different USB cable? Even before we acquired Netduino, I had good luck with the N3 boards. Do you think the board itself is borked?

I have bricked a lot of boards I just posted this it may solve your issues.

Yes, I have 6 2Pluses in service and use the same USB cable on them as I use on the 3.

I have been working on an app with commercial applications. I had hoped to move to 3 because there just is not enough memory on the 2 Plus for me to use more than 4 pins in my app, I believe there is enough memory that I could use all of the pins on a 3…I ported over to the wired version of the 3 more than a year ago and ran into the TCPIP stack problem. When I was unable to find a solution and went back to optimizing on the 2 Plus.

I then tried to get my Wireless 3 to run and it was just a brick from out of the box. I have had a lot of problems with the USB connector on the 2 Pluses as with my development I often need to reboot the 2 Plus a dozen or more times a day. I wish there was a hard reset button on the board instead of just a soft one. Anyway I had to retire a 2 Plus after a year or more because I wore out the USB port. I now use an USB extension and unplug the one cord from he other.

Let me know when you have a stable TCPIP stack and I will give the 3 another try as to me if I cannot communicate via TCPIP the Netduino does not serve my purpose.


Hey David sorry not getting back to you sooner.

Yes I have used that to wake up my 2 Pluses on numerous occasions. My wireless 3 is just DOA.

Thanks for posting this though it is important information everyone should have.

Hi Brian,

I just received a new WIFI 3 board.

I continue to have problems getting it to run the code at

I am trying to run on a closed network (no internet access)

If I do not use the DHCP enabled I get the following errors

A first chance exception of type ‘System.Net.SocketsException’ occurred in Netduino.IP.Linklayers.CC3100
A first chance exception of type ‘System.Net.WebException’ occurred in System.Http.dll (I get this one twice)

Then break at MakeWebRequest

This may be expected as the url is not reachable as there is no connection to the internet.

If I use the DHCP enabled
My IP Address, Subnet Mask and Gateway are all

I get the following
a lot of “Sleeping while obtaining an IPAddress”
Failed to get an IP address in the allotted time.
App finished

What do I need to do to get the demonstration app to work on a closed network?

You can generally ignore the exceptions; they’re just informational and only happen in debug mode. You can get rid of some of them by upgrading to the N3WiFi beta firmware.

On your closed network, do you have a DHCP server? You should get an IP address even if you don’t have internet connectivity.

Hi Bryan

I got her running today.

I am so excited to have so much more memory.