Netduino (1) Plus frmware update

Hello guys.
I have here an old Netduino Plus (not a 2 or 3, the old one).
I tried to update the firmware to 4.2 but the device is not appearing.
I connected the power whilst holding down the reset button.
It seems that every update I find is for the Netduino Plus 2, or the only Firmware I found is just some files like “ER_FLASH” and “ER_CONFIG” and I don’t know what to do with those files.
Could you please help me updating my firmware so I can use this device?

The instructions for updating the Netduino Plus 1 firmware can be found here

The latest firmware packages are on the Netduino Downloads page.

Hope this helps,

Thank you very much for this quick reply. I will try this instructions.

Ok, after erasing the netduino by applying 3,3v on the erase pad the Deployment tool says “Pinging… NoConnection”.
I also noticed that it disappeared in the USB selection, only the Serial device is available, which I tried to ping.

Sounds like you may need to use SAM-BA to get the Tinybootloader back on the board.

Try this troubleshooting post.

Don’t try following links to pages referenced as part of the Wiki as this is no longer available.


Maybe I’m to stupid or my Netduino is destroyed. I can’t get things working. It only shows as a serial adapter in device manager and I can’t get any connection to it.