N3 Setup Issues - cannot communicate

Have walked through the setup steps on a new computer, running Win10, VS2015, and a new N3 Wifi.

Installed the following in order:
netmfvs 14 dot net
Wilderness samples

I was able to run zadig and update the firmware on the N3 to WinUSB(v6.1). At this point the blue and white lights are on.

Loaded Blinky in VS
changed Properties so that I am running .Net4.3 and changed .Net Micro Framework from Emulator to USB but I cannot see any devices. Blinky errors out cause it cannot talk to the Netduino.

Went back to Programs and Features:
Confirmed that .net Micro Framework SDK 4.3 was installed
Confirmed that Netduino SDK v4.3.2 was installed

Went back to Device Settings:
STM32 BootLoader is installed under Universal Serial Bus devices – odd?
STM32 showed an error " STM32 bootloader was not migrated.
Removed STM32 device and driver

Rescanned system devices and NetDuino appeared under the Universal Serial Bus Controllers - good

Went back to VS2015 and Blinky - I can now see the Netduino 3 device in the .Net Micro Framework box - good

I can run Blinky but getting "debugging installer is not in an initialized state, rebooting …: and then … nothing.

Got any ideas?

Still plugging along.

Not sure what I did, but I am past the “debugging installer is not in an initialized state” problem. the status still shows the status message but it shows no errors a second later.

At this point, the program will compile, communicate with the controller, and appear to be working - but nothing happens. the on-board led is solid and does not change. I added the commands to activate a couple other LED’s on my proto board, and they are not lighting either.

I am open to any suggestions…

Post your code…

Here you go…

using System;
using Microsoft.SPOT;
using Microsoft.SPOT.Hardware;
using SecretLabs.NETMF.Hardware.Netduino;
using System.Threading;

namespace Blinky
public class Program
public static void Main()
// create an output port (a port that can be written to) and wire it to the onboard LED
OutputPort led = new OutputPort(Pins.ONBOARD_LED, false);
OutputPort led12 = new OutputPort(Pins.GPIO_PIN_D12, false);
OutputPort led11 = new OutputPort(Pins.GPIO_PIN_D11, false);

        // run forever
        while (true)
			led.Write(true); // turn on the LED
            Thread.Sleep(250); // sleep for 250ms
			led.Write(false); // turn off the LED
            Thread.Sleep(250); // sleep for 250ms


I removed all the drivers and did a complete re-installation from scratch

I also did several firmware wipes and update to WinUSB(v6.1.7600…).

I am back to STM32 BootLoader stuck in Universal Serial Bus devices and unable to see or access the board from VS. The driver is definitely having issues with this board and/or settings on my Win10 machine.

I am beginning to suspect that I may have a damaged board. I ordered another one this morning and will start the process over when that one arrives. With any luck, I will be able to determine if it is a board issue, firmware issue, or driver issue.

Have you tried using ST tools and MFDeploy to load firmware?

If you are talking, Netduino Deploy-Win-2.03 beta, then yes. Nice little program. Looking forward to it being a bit more robust and completely replacing Zadig and the current uploading process.

It did recognize the card as a N3-Wifi, but making the changes didn’t seem to make the card any more accessible.

I’m talking about defuse demo from ST and netmf mfdeploy.

Then nope.

I will do some searching and give them a try.


I did download and test using [ST tools and MFDeploy and still no go.

I received a different board on Saturday, plugged it in, updated the firmware and it worked beautifully. I then unplugged the second board and plugged the first one back in and it did not work.

So, I plugged the second board back in, waited, and was able to run Blinky.

The questionable board was Netduino 3 WIfi and had the numbers E385985 - 0217 on it.