Community

MeadowCLI.DeviceManagement.MeadowDeviceManagerException' was thrown

Everything was working Sunday Morning Dec 27. Monday morning, started getting the following error when trying to deploy:

‘MeadowCLI.DeviceManagement.MeadowDeviceManagerException’ was thrown.

I had changed nothing other than text in my files. I have tried creating a new HelloMeadow App, same problem.
I have a spare board that works. Same problem.
I have reinstalled everything, same problem.
I run as a Limited user, so I switched to the Admin account, installed everything as Admin, same problem.
I have tried copying files from the command prompt and using --MonoEnable, same problem.

Output from VS2019:
1>------ Build started: Project: HelloMeadow1, Configuration: Debug Any CPU ------
1>HelloMeadow1 -> C:\Users\Work\source\repos\HelloMeadow1\HelloMeadow1\bin\Debug\net472\App.exe
2>------ Deploy started: Project: HelloMeadow1, Configuration: Debug Any CPU ------
2>[12/29/2020 7:16:14 AM] Deploying to Meadow on COM9…
2>Exception of type ‘MeadowCLI.DeviceManagement.MeadowDeviceManagerException’ was thrown.
========== Build: 1 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========
========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========

I’m out of ideas. Any help would be appreciated.
Thanks, Paul

Hi Paul, I had the same issue. I got it resolved by updating the Meadow Extension. Under ‘Manage Extensions -> Updates’ I saw a new version. Installed it and did not get the error back (so far).
Geert

Turns out it was a problem with my USB3 Hub. Plugging the USB Cable directly to a Port on the Mother Board of my PC, solved the problem. Why everything had been working for a couple weeks, as it was, and then allowed me to communicate with the meadow using the command prompt, but would not allow me to deploy an App, I don’t know. Anyway, all is good for today.