Meadow not showing up in VS for Mac

Hi. i have deployed meadow OS on the device with dfu-util successfully. the board starts up and blinks RGB.
But the board does not show up in Visual studio (for Mac) community edition.

Is there supposed to be a serial port? the only thing i see is with lsusb which gives me:
Bus 020 Device 012: ID 2e6a:0001 2e6a Meadow F7 Micro Serial: 0

dmesg doesnt show any useful info.

any ideas?

Update, There is a serial device /dev/tty.usbmodem01 created (missed that. sorry!)
and i can connect to it with screen and see output “state:” from the blinky program.

but still nothing no target showing up in Visual Studio.

Same thing for me, does anyone know how to fix it?

I’m hitting the same problem. Did either of you get it worked out?

I am also stuck at this point on MacOS. I know nothing about Visual Studio. I seem to have the HelloMeadow app set up in VS. I see the usbmodem01 device and can connect to it using the ZOC terminal emulator. When I connect, I see this single line of output:

[SERIAL/DIRECT] CONNECTED TO PORT /dev/cu.usbmodem01 (115200-8N1)

Mono enabled, will run app.exe

I followed the DevCamp2020 Getting Started video and see where the Meadow serial number should appear in the box next to the word Debug. I have reset the board multiple times followed by closing and restarting Visual Studio. The box always shows Default.

I have no feel for how the “connection” should automatically happen and would guess that if one had multiple Meadow boards connected there should be a way to select the target, but have not found any menu that allows searching for a board.

I will continue to stumble around but am certain my lack of knowledge likely requires some assistance in order to get further.

Thanks, Chuck

No progress, I haven’t been using the meadow for some months but gave it a try a couple of days ago. i have just set up a new MacBook Pro, installed Vs for Mac and meadow. No connection to meadow. Latest fw. I downloaded the source for Vs extension and I’m currently trying to figure out what fails.

Not encouraging! I do not want to wake up the old Win 10 machine but may need to try that to verify I can get something to work. Thanks for the update.


I have notified the team about this and we will investigate what’s going on in the extension for VS4Mac, and hope we can get an update sorted with this deploy issues fixed.

Hello ,
I have the same issue. when I “dfu-util --list” i can see the device, but in VS2019 it’s not showing.
During the install I was getting some issue with this command: mono ./Meadow.CLI/Meadow.CLI.exe --WriteFile -f Meadow.OS.Runtime.bin
I keep getting this error:
" Data: File download to Meadow failed to start for ‘Meadow.OS.Runtime.bin’
Request Error
Data: HCOM received unsupported protocol version:0112, expected:0006"

Hi, I just purchased my board and I’m having a similar issue. The board doesn’t show on Visual Studio for Mac.
This the the result of running ioreg -p IOUSB
±o Meadow F7 Micro@14100000 <class AppleUSBDevice, id 0x100000f89, registered, matched, active, busy 0 (4 ms), retain 13>
Among other devices. But in Visual Studio, it shows up as Default in the device tab.

I just wanted to make a small update. I tried on a VM with Windows 10 and the deployment phase to the board fails. This seems to be a known issue, so I’ll not repeat it here, Meadow deployment issues. I just mentioned because it seems I have no windows 10 alternative to work on the board, which is very disappointing.
It seems the first complaint in the forum was made on Feb 3rd, a long time ago by today’s standards. Does anyone have any update on it, or ideas for a workaround?

Thank you

For me, this issue could be considered closed. I just received the new update for Meadows in VS for Mac. So far, everything works perfectly.