Community

Meadow not booting on power supply

Hi guys,

When connected to visual studio, the boards works, but when connected to usb to power only with a working adapter it doesnt startup.

Is there something I need to do differently?

You should not need to do anything special. I have connected Meadow to both battery and a USB power supply and the board boots as expected in both scenarios.

Are you using the USB for power or providing power over the 3.3V or 5V pins?

Regards,
Mark

Hi Mark,

I am running the simple hello world with rgb led. Not connected anything yet.

It only works connected to vs. It doesnt matter if i reset it or starts it in boot and then resets it.

And yes, using usb fof power with different usb adapters to test

I have now tested this from my windows 10 laptop, and whenever it is connected to something and recognized as a serial device, it starts working, so it must be “waken” by the data connection in the usb. I am yet to test a power supply connection directly to the board

I have 2 boards, bought at the same time and it is having same behaviour - works when connected to usb on a turned on computer, but not when connected to a usb power adapter. it is revision 1.d

I just tried adding 5v to the 5v pin and gnd to gnd - i measure 4.9 volts on the input to the board, but it doesnt respond at all. If i connect it to usb it works and i meassure 5v on the 5v pin…

I dont get it - this is the case on both my boards - my patience is running out :frowning:

Do you know which version of the OS you are running on Meadow?

Reason for asking is we think we had a regression in 3.8 which causes the problem you are seeing and using 3.7 may fix the problem. Here is the Meadow beta 3.7 download

Regards,
Mark

According to vs2019 i am running 3.9. But I will try using 3.7 to see if it helps me. Thnak you

I just tried to downgrade to 3.7 on my mac by changing the url on the link you send. Still the same - it works when I connect it to imac, but not when only to power source.

We think we have this fixed and the software is currently being tested.

I’ll keep this thread updated with progress.

Regards,
Mark

This should now be fixed, see the beta 3.10 release notes for more information.

Regards,
Mark

Thank you, I have just uoloaded new FW and it is working - thank you very much!

Glad to hear you are back up and running.

Regards,
Mark