Community

Meadow device not detected

I’m having trouble deploying Meadow OS to my Meadow F7. I can’t get the device to be detected by any computer. I have tried on three computers with Windows and one Mac. I have tried flashing from both the Visual Studio extension and with the dfu-util but none of them works. I connect the USB cable while holding the BOOT button and when the power LED flashes once I release the button. If I then try flashing with the Visual Studio extension I get an error message “Device not found” and if I use “dfu-util --list” then an empty list is returned. I have tried using two different USB cables so I don’t think that’s the problem. Am I missing something or is my board broken? Is there anything else that I can try? I haven’t soldered the connectors yet so I haven’t broken the board with bad soldering. If I connect the USB cable without holding the BOOT button then an RGB LED starts flashing after a while.

It sounds to me like the USB cable probably IS the issue. You should make sure you have one that can do data transmission and not just provide power. You can troubleshoot them with a cellphone or tablet to see if the cables provide data transmission on one of those vs. just powering it up. When it’s connected, you should see an available COM port in the ‘Select Target Device Port’ drop down in the Device Explorer.
Can visit the troubleshooting page if the issue still persists: http://developer.wildernesslabs.co/Meadow/Meadow_Basics/Troubleshooting/VisualStudio/

I tested a third cable and that one worked. I had no idea that they make USB cables without data and apparently I have at least two of them. :grinning:

Thank you so much for your help @kevy-c

Glad to hear it! I went through a handful of cables myself before I found one that worked.