Community

Is my Meadow dead? Red LED blink :S

Hi, today I was going to play with the new beta released, but when I connected the USB to my board, the only thing that happens is a micro red blink in a LED that is marked in the picture.

I tried to read about it, but could now find anything related to it.

Is my Meadow fried?

I tried to plug the USB with the boot and reset buttons at the same time, but nothing happened, just a micro read blink, no USB recognized by my computer, nothing.

Thanks in advance for the help.

-ed

Hello Ed,

Apologies for the very late reply. I want to follow up on your case, is your board still not responding at all? No signs of life according to the Device Manager (if you’re in Windows)?

That small orange/red LED that its lighting up is part of the charging circuit. It normally turns on when you connect Meadow and it has a LiPo battery connected there, to indicate its charging. The LED might flash for a split second when you connect it to your computer, but it should work normally.

If you still cant get your board to work, please write an email to hello@wildernesslabs.co, and we’ll assist you with the next steps.

Thanks,
Jorge