How do I get rid of the debugger once and for all?


Attaching debugger engine...
... cannot attach debugger engine!

I almost thought I had it fixed, but it gets coming back as a bad penny! I’ve reflashed the board, I’ve uninstalled the driver and reinstalled it. I’ve managed to run the hello world program with the attached led, from the pages. It seems I finally succeeded getting my Netduino working again. I created a project, ran the “Build” function and ran the “Deploy” function. No debugging involved. A working program deployed to my Netduino.
But then I had to test writing on the SD card, so I looked at the SDCardIO program. I carefully deleted each debug call from the code. Then I did Build and Deploy. And the #¤%& debugger engine gets attached again! To no use! “…cannot attach debugger engine!”
Well, the engine is obviously totally busted and corrupted! But what should I do to get rid of it alltogether? Where is it? What is it? Is it a dll file somewhere, which can be deleted? At the moment I really don’t care very much of having it repaired, I’d rather have it removed like a cancer. I already saw the hello world program beautifully work without anything debugger related. Right now I know I’m back in the “cannot attach” swamp, having to wipe, uninstall, reflash, whatnot, to get it running again.

Update to my experiences

Ok, so I used NetduinoDeploy.WPF.exe once again to install the firmware again. And I managed after that to deploy the NetduinoApplicationBLINK project. It worked. And I also learned that the debugger indeed was attached successfully. This is an engine meant for the deployment process, not for debugging, right? Lesson learned.
Then I did the following. I detached the Netduino from my computer. Then I reattached the Netduino. Then I did the deploy project thing. And now: “… cannot attach debugger engine!”

There’s no way for me to deploy a program more than one time, after re-installing the firmware.
I’d like to hear people’s comment on this, especially from Wilderness staff. But also from other users. I know some of you have had similar problems.

That doesn’t sound right. We redeploy new apps and builds all the time. Have you tried right-clicking on the project and doing “deploy?”

Right now I think my board works ok. I can deploy new versions of my program and it receives them nicely and starts them. I still don’t know the fundamental reason for the problem, but it has something to do with my program causing a crash, which means the Netduino can’t receive a new program.

1 Like