Community

Help with Getting Started on Windows With New MeadowBoard

Hey everyone,

I’m really struggling getting started with my new meadowboard with VS 2019 on my Win 10 machine.
I was able to get the extension installed on VS no problem.

But I got very confused on flashing to the new Meadow OS.

The online tutorials just seem to show updating Meadow OS through an old VS extension feature that was removed. So that is no help to me now.

On the online guide here:

I was able to do all the prereqs, including updating my USB driver for ST devices.

But where I get stuck at is step 3.

The tutorial makes it sound as easy as typing “Meadow.exe -flashos” but when I try it that command I get this:
Command I run:
“Meadow.CLI.exe -flashos”
Response I get:
“Opening port ‘erial’…port not available”

Even if I didn’t get that error, I still have no clue where the flash OS command would be pulling the new binaries from.
Shouldn’t they be pulled in as an argument or something?

I also am confused as to why its looking for a serial port, when I used Zadig to remove it from my available serial ports in Windows.

I’m also confused as to if I need dfu-util to install this on Windows like OSX or Linux.

Could we have a separate install pages for Windows, OSX, and Linux? Merging them together in one page is really, really confusing me. Its not super clear which steps are exclusive to what systems.

I will really appreciate any help!!
Thanks
-Phillip Davis

Hi,

sounds like the Meadow is not in BFU Bootloader mode.

After performing the Prerequisits, which in your case are the Windows ones, you have to perform the Steps 1 to 3. Step 1 is where you download the binaries. The bold written headlines in each step contain information specific for different OS. So at each step you additionally have to check if there is something Windows specific.

Hope this helps,
Daniel

Hi Dani,

In the prereqs for Windows, I install the USB driver for ST devices (which in effect removes the Meadowboard from my available USB ports.

In step 1 I download the binaries, this makes sense.
In step 2 I have to put the meadow in bootloader mode, which makes sense.

In step 3, it says flash the Meadow OS on with the command “meadow --FlashOS”
Which the meadow promptly responds with “Please specify a serial Port”

Now how can I specify a serial port, when in the prereqs I literally just removed the device as a serial port?

I feel so confused.

I am quite new here but as far as I have understood it for the OS flashing it should not require a port. I think it is correct that the Meadow is not listed in “Ports (COM&LPT)” when in boot mode, but I am not 100% sure. I am working on Ubuntu so there the things are a bit different but during boot mode it the Meadow is not listed with a Port.

Hope someone else reads this and can give some advice.

I am in the same boat. I went through the steps for Windows. Flashing seems to have worked based on the screen response. But when I hit reset (or unplug meadow) I don’t find meadow in device manager/com ports. It shows up under Universal Serial Bus controllers with the following error…

Unknown USB Device (Device Descriptor Request Failed)

I am stuck with a non-functioning Meadow at this point.

Yeah, I’m pretty confused too.

Barry

Thanks for joining in Barry,

Sounds like your one step ahead of me. How did you get it to flash?

I think once the flash is successful you need to turn your device back into serial port mode. Which can be done through removing it in device manager and forgetting the driver.

Hi Phil,

  1. I used Zadig successfully.
  2. Put Meadow in bootloader mode.
  3. Bring up command prompt in Windows.
  4. enter… meadow --FlashOS

A screen full of activity ending with

'File downloaded successfully
'Transitioning to dfuMANIFEST state

At that point I unplugged/replugged Meadow. It should have shown up as a serial USB device in Device Manager. It doesn’t… instead I get this error under Universal USB Device controllers…

Unknown USB Device (Device Descriptor Request Failed)

I have repeated the steps several times with the same result.

Barry

Hey Barry,

I just made it finally to where I can deploy applications. I did get the
“Unknown USB Device (Device Descriptor Request Failed)” a few times.

Did you make sure to only use Zadig AFTER you put it into bootloader mode?

From what I understand, the meadowboard has two states, the Boot state and the Regular state. And both show up differently in Windows as different devices.

You want the driver for the boot state to be overwritten in Zadig, but not the regular state.

The Regular state should show up in Windows as a COM Port.

Hope this helps.

I made it past my problem, but now if I deploy an app I get absolutely nothing. The meadowboard doesn’t cycle the LED and the VS debugger just closes after deploying. So many problems! lol

You’re making headway!

There are a few more steps after flashing. Maybe you missed them in the ‘getting started’ mess…

Reset the device (push the RST button or disconnect and reconnect) and identify the serial port name that the Meadow is connecting on using Device Manager:

USB Serial Device [COMXX]:

Once you’ve identified out the port name, run the following:

meadow --MonoDisable -s [COMXXX]
meadow --MonoUpdateRt
meadow --FlashEsp
meadow --MonoEnable

Unplug and replug Meadow to give it a full restart.
Your board is now ready to have a Meadow application deployed to it!

I’m still stuck… unable go get device manager to recognize Meadow as a USB Commport following reset. Wonder if there is a way to reset Meadow back to ground zero and start over.

Update… Still having problems, but now they are different problems.

I used the command
meadow --EraseFlash
followed by
meadow --FlashOS
That appeared to be successful and now I see USB Serial Device COM8 in Device Manager.
The problem that I have now is when I continue with the next steps.
meadow --MonoDisable -s COM8
That appears to work…
But then
meadow --MonoUpdateRt
fails with this error…
An exception was caught: system.io.ioexception: a device attached to the system is not
functiioning: COM8

When I run
meadow --MonoEnable
I get an different error…
meadow will not start mono because the following files are missing:
system.core.dll
system.dll
meadow.dll

Any help will be greatly appreciated…

Barry

I found this in the Troubleshooting section…

You’ll typically need at least the following six files installed to the Meadow flash to run a Meadow app:

  1. System.dll
  2. System.Core.dll
  3. mscorlib.dll
  4. Meadow.Core.dll
  5. Meadow.Foundation.dll
  6. App.exe (your app)

It’s a good idea to disable mono first, copy the files, and then enable mono.

Where do I find these files and how do I copy them to Meadow??

Barry

I had problems until I switched my USB cable… apparently they are not all created equal… some are incapable of using the “data” line (did I get that right?). Anyway, I found some cheap cables on Amazon and presto… my laptop was now correctly communicating with my Meadow over my serial port.

ok then… I bought a second Meadow and followed the all of the same steps. This one works. The big difference that jumps right out at me is a bright orange (red?) led (located near the usb port) that is illuminated on the non-functioning Meadow but never on the new (functioning) Meadow. I’ll start looking for clues to see if that is indicating a problem with the Meadow. If anyone already has the answer jump right in!

Barry

I have a known good working Meadow.

I successfully ran “meadow --FlashOS” and afterward I was able to run the --ListFiles command.

Then I messed up and ran “meadow --FlashEsp -s COM6” without running the --MonoDisable and --MonoUpdateRt commands first as directed above:

meadow --MonoDisable -s [COMXXX]
meadow --MonoUpdateRt
meadow --FlashEsp
meadow --MonoEnable

Now the I cannot talk to the board unless I’m in DFU_UTIL mode (so there’s hope), but I can’t get applications to run.

Also tried running the 4 command sequence above in DFU_UTIL mode and no luck.

Any advice?

William…
I heard back from Peter Garafano (Wilderness Labs Support) support@wildernesslabs.zendesk.com 10 days ago. He said he thinks I have a bad board and they will be sending me a new one. I haven’t heard back since then…

Maybe your board is bad too.

Good luck…
Barry

I received a replacement Meadow thanks to Peter Garafano (Wilderness Labs Support). I flashed it with no problems.

Thanks,
Barry