Help with Firmware update Netduino Plus

I have a Netduino Plus and I decided to update its Firmware. I erased the old firmware v4.1.1.0 (By placing a wire between the 3.3 volt and the gold pad) but when I try to deploy the new Firmware I can’t because MFDeploy does not see the Netduino. The led by digital pin 1 stays on. Can someone help me. I also tried your new updater and it also does not see the device.

Thanks in advance

  • Unplug the device
  • Hold down the button
  • Plug the device back in
  • Let go of the button

that should put it in DFU mode.

The new updater is designed for use with the Netduino Plus 2/3/Wifi as they are built using the STM32 microcontroller and so this will not work with the original Netduino Plus as that is an Atmel chip.

I would grab the firmware from the 4.2 page. Now this has a step in it that refers to a Wiki page that has long since gone. However, the instructions can be found on the 4.1 firmware update page.


1 Like

Thank you for the assist. Using that I erased the 4.1 version of the firmware and updated it to 4.2.
I did this through SAM-BA and then MFDeploy 4.2, but it looks like I lost my network capability even though through MFDeploy I set up the Network with the MAC address and setting DHCP enabled.

I just noticed that using SAM-BA and the MFDeploy This will give you 128KB of Flash and 60KB of RAM–but will remove the lwIP networking feature.

How can I get that feature back?

Can you please help

Please disregard my last post. I tried it again today and it works like a charm and was able to get the DHCP to work.

Good to know that you are back up and running.


Now I do have an issue though with the Netduino 4.2 SDK and 4.2 firmware I can’t get my one-wire device to work. I was previously using an experimental firmware for 4.1 from CW.NETMF.Hardware for the DS18B20 temperature probe but it will no longer work.

I found an old post on the old form

but it has an attachment that I could not get to.

Do you know of any support the the onewire protocol?

Try this:

Wasn’t the OneWire class introduced in Microsoft.SPOT.Hardware in version 4.3?



It is in my 4.2 assemblies. Need to add ref. to Microsoft.SPOT.Hardware.OneWire



Also, my apologies for steering you wrong on the DFU mode. I thought you meant Netduino Plus 2.

I’ve been trying to use the Microsoft.SPOT.Hardware.OneWire protocol but whenever I access oneWire.TouchReset() or oneWire.FindAllDevices() I get the following error System.NotSupportedException. I am using your firmware for the Netduino Plus V1.


Should also mention I am referencing Microsoft.SPOT.Hardware.OneWire in my project.

To Install SAM-BA 2.15, I reset my Netduino Plus (by pressing 3v3 and gold squre near io0), َAfter that, when I do connect my Netduino Plus 2 board to PC via USB cable its not showing in the device manager. Please help me.

You start by mentioning Netduino Plus and then move on to Netduino Plus 2.

Can you please confirm which board you have Plus or Plus 2?

In order to upgrade a Netduino Plus you would use Samba.

To upgrade a Netduino Plus 2 you should follow the instructions in the firmware update guide.


Any luck with getting the Onewire protocol to work?