Getting started before "Getting started"

I’m quite new to Netduino. I come from the GCC world, so it has been more C/C++, CodeBlocks and GCC for me than Visual Studio and C#.
I tried to follow the link on this page.

But it seems to expect that I already have Visual Studio. Never was that mentioned. On the next page following the link were things to get installed. The second line had a link, “Visual Studio 2015”. But it was only for NETMF Plugin for Visual Studio, whatever that is. I don’t know, because I’m only getting started. So I abort the download by clicking a link ‘back to download page’. Now I seem to get to a page that does indeed have a link to Visual Studio download from Microsoft. This downlad page looks much more appropriate for getting started than the actual getting started page.
Too bad Microsoft messes it up for a newbie this time. The link promises VS 2015, but the Microsoft page starts to bbrag about VS 2017 instead and does a good job confusing me and hiding the free version of VS 2015. I thought I found it finally and downloaded an installing file. After having installed it - I had to have an admin guy in our community to run the installing with his admin rights - and testing the program after returning home, I found out that I had VS 2017 installed. So I got fooled by Microsoft to download the newest version!
Wilderness can’t do anything to Microsoft’s confusing pages, but you could have a proper link to the right page to Microsoft’s site, from where VS 2015 is downloaded. And installing VS 2015 could be mentioned as one step on the Getting started page.
I am still a bit confused and I’m afraid I haven’t been able to describe my struggling clearly. But my impression of the Getting started page is that it’s writtenfor someone who knows exactlywhat each step is for, what each downloadedfile actually is. Not for a newbie, who might know C/C++, Arduino and whatnot, but not .NET, MSVS, C# etc.

I feel your pain took me 4 days to figure it out …Try the second tutorial on the first one has something missing …so it wont compile properly and throws errors …the second one worked for me …After I figured out where everything was …Arduino IDE is much easier to work with but I think these devices might fill a gap for higher end computing and sensing …

oh man, sorry you folks had so much trouble. looks like we missed the VS 2015 part altogether on the windows setup page. :smiley:

The downloads page has the best link we could come up with for VS2015. We’ll get that link added to the windows instructions page as well.

Not a big deal. It’s a question of time when I’ll have it all set.

We got this fixed, thanks for bringing it to our attention!

One more thing! The “Getting started” page mentions .NET Micro Framework (.NETMF) v4.3.2 - QFE2 SDK. I followed exactly the procedure on that page, I installed everything on a crisp new Microsoft Surface. I tried the Blynk app. I got an error when I tried to run the program, “0x80131700” it said, nothing else. Some Googling revealed to me that the newest version of .NET Micro Framework is not enough, it expects an older to be present, too. So I downloaded version 3.5 of .NET Micro Framework.

And now my Netduino is blynking beautifully! So according to my experience, to get the Netduino to work, you have to download and install both version 3.5 and version 4.3.2. of the Framework. As I said, my computer is brand new and I did a reboot after the first failing and before downloading and installing 3.5 and retesting the Blynk sample. Anyway, now it’s working.

wow. that’s news to me!

has anyone else had that issue?

According to Google, yes.

But, as I wrote, I’m in the middle of getting my new laptop working. So either it was the rebooting or the older Framework that fixed the problem. But according to some of the writings I found on that very Google search, the setup really needed an older Framework to work. That might be the case, because my brand new computer has absolutely nothing but Windows 10. Perhaps no one has ever tested this on any other machine than one with a lot of old stuff already installed in the system.

I think there may be some confusion here. I think this should be 3.5 .NET Framework. In actual fact I think it is the .NET 2.0 framework that is required and this is included in the 3.5 framework but not the latest version of Windows.

I’ll add this to the documentation.


1 Like

Jordan: thanks for reporting this, documentation has been updated.


1 Like