Firmware Update (Windows)

Just received a Netduino 3 and am really excited to get going again. However, I tried to go through the firmware updating process to but wasn’t able to get it to succeed.

The instructions for MFDeploy say to select the ER_CONFIG and ER_FLASH files but at least the version of MFDeploy I have requires a hex file and the firmware provided are in s19 format. I could get the files selected by putting in . into the file name text box but the deployment then failed (fortunately, the device didn’t brick). I understand s19 files can be converted to hex but I didn’t want to explore that option as I can work with the device with the firmware that it shipped with.

Hopefully I’m just missing something but have done this process on almost every other Netduino (and other um’s) and something seems to be amiss.

Get the Netduino SDK located here:

Unzip the file to your computer and locate the firmware directory.

Click on the NetduinoUpdate.exe file and select your Netduino firmware.

Unfortunately, I tried that as well and nothing shows up in the window to update.

Sorry, you can rename the .s19 files to .hex.

It’s on my list to fix:

Still having trouble with this. The *.s19 files from the download on the site can be changed to hex but still program the N3 as version When I tried the files on the GitHub link, I get an error in MFDeploy stating the file is in the wrong format (I also updated the *.xml to refer to hex instead of s19 but it didn’t help).

I’ll wait it out.

Try putting the board in bootloader mode (Press and hold your Netduino’s pushbutton while plugging it in via USB; this will put it in bootloader mode) again.

1 Like