Driver update not working

Using zadig-2.3.exe I have changed USB driver in the PC to STM32 with success.
After when I try to do Netduino update(v.1.0.2) my device (netduino Wifi) is not displayed and can’t do corresponding update. Device manager is showing Universal Bus devices/STM 32 bootloader (driver version 6.1.7600.16385) when in this update phase.
Normally connected Device Manager is showing Other devices/Netduino 3 Wi.Fi in faulty condition.
I am using Windows 10 and Visual Studio 2017.
Please help me.

Hi Fernando, sorry to hear you’re having issues.

Bootloader Mode:
Have you tried using the new Netduino.Deploy tool? You can find the download link here: Beta of Netduino Deploy for Windows and Mac!

It’s been designed to work with latest version of WinUSB.sys which can be installed using Zadig. Instructions here:

Normal/development Mode:
It sounds like the drivers may not be installed. To get setyp for development, you’ll need Visual Studio 2015 and you’ll need to install the .NET MicroFramework, the Netduino SDK and the Visual Studio 2015 plugin. Links and details are here:

The current stable release don’t support Visual Studio 2017 (but that may change in the future)

Please let me know if I can answer any additional questions.


My Netduino 3 wifi still not deploying applications. Meanwhile I can build them without problems.
Running zadig-2.3.exe in DFU-bootloader mode I am able to change driver.
Again in DFU-bootloader Mode NetduinoUpdate it is not detecting any device.

Now, I am able to deploy applications after to have deactivated imposition of controllers signature in Windows Settings/Update and Security/Recovery/Restart Now/ Troubleshooting /Advanced Options/Startup Settings - restart/ option 7.
NetduinoUpdate still not detecting corresponding device.

After doing tasks reported in my last 2 preceding replies USB controllers doesn’t work properly, as far as I understood zadig-23.exe has changed USB behavior being not possible to recover from it using explained procedures. To solve this situation I recover windows and wait for a regular USB driver for Netduino.