Debugging problem


How to solve it?

I am getting this also - it is really annoying.
No matter if I hit F5 or Ctrl+F5, this message always pops up.


I am having the same problem has anyone fixed this? Is it something I did not install?

Debugging is not working for me since I updated to vs 2022.I have the following versions installed:
Microsoft Visual Studio Community 2022 (64-bit) – Current Version 17.3.4
VS 2022 Tools for Meadow Version: 0.19.2
Mono Debugging for Visual Studio 17.3.20 (3f4cb00)
Xamarin (d17-3@a0ff24b)
Xamarin Designer (remotes/origin/d17-3@e4f67afef)
Xamarin Templates 17.2.28 (9b3d244)
Xamarin.Android SDK (d17-3/030cd63)
Xamarin.Android Reference Assemblies and MSBuild support.
Mono: dffa5ab
Java.Interop: xamarin/java.interop/d17-3@7716ae53
SQLite: xamarin/sqlite/3.38.5@df4deab
Xamarin.Android Tools: xamarin/xamarin-android-tools/main@14076a6
Xamarin.iOS and Xamarin.Mac SDK (87f98a75e)When I deploy a C# app I get the following error but the app runs correctly on the meadow f7 v2.c
Method not found: ‘Void Mono.Debugging.VisualStudio.StartInfo…ctor(Mono.Debugging.Soft.SoftDebuggerStartArgs, Mono.Debugging.VisualStudio.DebuggingOptions, EnvDTE.Project)’. (edited)

I also have this issue. Any ideas on resolving this?

Hi @moweee, meadow and @meldundas If you upgrade to VS 17.3.5 of 17.3.6 do you still get the same error?


Hi @Dominique.Louis
Yes I have tried upgrading. I am using currently using:
Microsoft Visual Studio Community 2022 (64-bit) - Current Version 17.3.5
I also tried:
WildernessLabs.Meadow.CLI –-version 0.19.9-beta
No luck yet!
Screenshot 2022-10-09 153450
Thank you,

Hi @Mowee,
Could you please try this special vsix build (I’m on the dev team. not some random :slight_smile: ) -
Seems VS Community has a different signature for that constructor, compared to VS Professional :confused:


I have VS 2022 Enterprise and I am getting the same error message


@Dominique.Louis - I used the special vsix and it fixed the issue for me. Thanks.

Hi Dominique, that solves it for me. Thank you. Debugging is now working. :grinning:

Worked for me as well. Thanks!

Ran into an issue and had to revert back to the production extension. When I create a new project and choose Meadow Application, the template didn’t generate the Program.cs file and it left out the second argument for the inherited App class in MeadowApp.cs

public class MeadowApp : App (<- Errors with “Using the generic type ‘App<D, A>’ requires 2 type arguments”

Should be → public class MeadowApp : App<F7FeatherV2, MeadowApp>

When I reverted back, that was fixed in the project template.

This is because the new templates are for the upcoming RC1 release.

1 Like

Hopefully everyone in this thread has now updated to RC1, which has quite a few stability fixes.