Connecting to Meadow in VirtualBox

Hi all,

Just wondering if it is possible, and anyone has successfully connected a Meadow F7 inside VirtualBox?

I have a Windows 10 host and Windows 10 guest. The guest has Visual Studio Community 2019 installed in it. I have managed to connect to the Meadow and update the firmware/OS via the host OS.

When I try to deploy to the Meadow inside VS2019 in the guest VM, I get various error messages about the device being unavailable. The Meadow extension in VS is recognising that a device is connected (on COM3).

[Note: I have successfully connected to the Meadow and deployed a program to it with VS2019 on a PC without VirtualBox and that has worked. I would like to be able to code and deploy from a VM].



I can’t answer your question but as you’ve not had any replies. I do all of my development from within movable vmware virtual machines so I don’t think you are asking too much to want to work this way. My hardware is now custom and uses usb/network. Issues I’ve had include usb compatability modes 2 or 3 and mapping com ports through to the VM properly. I’ve used several different RS232/usb leads mapped into vms without an issue. Also need to make sure the VM has exclusive access to the device and not the host. Not an answer as such but maybe some food for thought?

Thanks Jason,

I’ve tried numerous things over the last few weeks, different cables, mapping COM ports, different USB drivers etc. and nothing seems to work.

Yesterday I updated to the latest firmware and OS via my VM and that worked fine, so I suspect there may be an issue with the Meadow VS Extension and the virtual USB port - I say that because, when deploying, VS seems to initially recognise that the Meadow is there and connected, but at some point loses connection and the deploy fails.

I might try putting something on the Slack channel and see if I get any responses there.