Build error (system.exception)

Everything working as it should and now this error is thrown…not sure what has changed and what the error is trying to tell me but it will not build anymore. Any ideas?
Netduino 3 Wifi
Visual Studio 2019

Turns out i had an error trying to multithread in program.cs

And what did you do before to enable VS2019 to enable working with and successfully making code for the devices work properly? I tried VS2019 earlier and it didn’t work.

The same process for 2015…installed prereqs and added references. However i am getting my same error again after adding another sensor, i just can’t figure it out.
What version are you running?

I’m running VS2015. I simply followed the steps. However it took a massive effort to restore the OS onto this fellow. Further, I had gotten it to work before switching temporarily to the dreaded Microsoft Windows Insider Builds. Those are a sort of rolling builds with creep from an Alpha that should have been allowed out to a Beta that can be allowed out reluctantly. And as it happens I just tried out one of my favorite Netduino activities, one of running a logic machine that produces results from toggling the input lines to a programmed PAL16L8 devices, in this case it was made up as a HAL16L8 and branded for the (late) Atari folk for their computer efforts. It was made up as an MMU for their kludge of a series of computers. See here, Atari MMU Basically I collect and attempt to reuse such programmed parts. I also have a small collection of blanks, and the software to program them, its the programmer I do not have. A friend has offered to program them.

Doctor Who
“Human beings are quite my favorite species.”

Well you’re light years ahead of me, i’m simply trying to get 4-5 sensors to fire their respective relay and open a water valve in response…still having trouble with it. Every time i add a new sensor it won’t build, its acting like it only wants one working at a time however i am using voltage divider circuits on each input pin and i didn’t have the right resistors to get 3 volts required to satisfy the N3 (should be arriving tomorrow).

Thank you!
I’m not in the neighboring star system, (4.3 Light Years, for Alpha C.) I’m right here in Queens New York. But I’ve been doing this since the Secret Labs days. Did you try and use VS2015 .first? It happens that the release I’m using is the exact same one described on the site. Originally Secret Labs wanted people to use VS2010 or VS2012 or VS2013, depending on what versions of Windows they were running. I started with Win7SP1 and VS2010, and was successful at it. Tried 8.0 and 8.1, and got slow responses, but it worked with VS2012 and started with a late release of VS2013 here. Then it became clear that VS2015 was the way to go. There are efforts to convince or confuse Microsoft to make the right things available for VS2017, but so far it took an outside consultant to seemingly make it work, it does not here. Now what we need are the tools to do all this heavy lifting which are callable from Visual Studio Code.

Doctor Who
“Oh not again!”

Yes, i did try 2015 first and had just started flirting with 2019.
I was a junior developer back in 2006 so most my experience is with 2003 and 2005 briefly, and needless to say i am a little out of the loop with .net and the most recent studio versions, .net 2.5 was just barely being implemented at our office when i was exiting…haha.
Anywho i think ill stick with 2015 as is not giving me as much of a headache to keep working.

On another note i’m trying to figure out a 12 volt DC to 24 volt AC inverter to implement into my project…do you have any experience with this? and honestly i would mind just buying a prebuilt module and plugging it into the circuit.