Community

Any tips on getting the Meadow F7 board to show up in Visual Studio?

I just got my board and I was able to follow along with the documentation and put the device in bootloader mode and install the OS using dfu on windows. I also installed the VS extension. The board shows up in device manager.

But the device does not show up in Visual Studio Meadow Device Explorer (ctrl -> shift -> m).

Well it turns out I got it working. Just an FYI I am running Windows 10 when trying to get connected to Meadow F7 with Visual Studio 2019. But I had to do the following to get my device to show up as a COM port.

  1. In Device Manager I selected the Meadow F7 Micro and uninstalled the drivers making sure I removed the drives from my machine.
  2. Unplug the meadow F7 board from the USB cable
  3. Rebooted windows
  4. Plugged the meadow F7 board back into the serial port
  5. The device drivers installed on their own and came up as a COM4 serial port

Now the device shows up in visual studio and I can deploy my application to it.
.

Out of interest, when you put the device into boot loader mode and installed the OS, did you reset the board afterwards?

My reason for asking is that following an OS install you have to reset the board which unplugging it will do. Just wondering if we need to update the documentation.

Regards,
Mark

I did reset the board after the OS update. I did it first by the reset button and the COM port did not show up. I did it a second time by unplugging the board from the USB cable. The board still did not register as a COM port. I also uninstalled the drivers, unplugged the board and re-plugged the board back in and the board still didn’t register on a COM port. The final steps I did was what was mentioned above which also included a re-boot of windows. I don’t recall if I tried to re-boot windows without uninstalling the drivers first.

Hi Mike
I seem to be having the same trouble as you, however I have tried everything and it is still showing up as “Meadow F7 Micro” in USB Devices after removing drivers and restarting.
Can you tell me what is should show up as? Is it in USB Devices or under legacy Hardware in Ports(COM&LPT) ?

Once it started working it showed up as “USB Serial Device (COM3)” under Ports (COM & LPT) in Device Manager. Yours may not be COM3.

Thanks mate. I tried it several times with no success. But did get it to work eventually. I think i may have installed a different driver with zadig. restarted. then installed the correct driver. restarted then it turned up. It may help someone else.

Hi! thank you Chainsoftwarejeff for your answer.
can u please tell me, what exact driver did you installed?
i cant start my Meadow from Windows 7 :frowning:
thank you