Community

Any tips on getting the Meadow F7 board to show up in Visual Studio?

I just got my board and I was able to follow along with the documentation and put the device in bootloader mode and install the OS using dfu on windows. I also installed the VS extension. The board shows up in device manager.

But the device does not show up in Visual Studio Meadow Device Explorer (ctrl -> shift -> m).

Well it turns out I got it working. Just an FYI I am running Windows 10 when trying to get connected to Meadow F7 with Visual Studio 2019. But I had to do the following to get my device to show up as a COM port.

  1. In Device Manager I selected the Meadow F7 Micro and uninstalled the drivers making sure I removed the drives from my machine.
  2. Unplug the meadow F7 board from the USB cable
  3. Rebooted windows
  4. Plugged the meadow F7 board back into the serial port
  5. The device drivers installed on their own and came up as a COM4 serial port

Now the device shows up in visual studio and I can deploy my application to it.
.

Out of interest, when you put the device into boot loader mode and installed the OS, did you reset the board afterwards?

My reason for asking is that following an OS install you have to reset the board which unplugging it will do. Just wondering if we need to update the documentation.

Regards,
Mark

I did reset the board after the OS update. I did it first by the reset button and the COM port did not show up. I did it a second time by unplugging the board from the USB cable. The board still did not register as a COM port. I also uninstalled the drivers, unplugged the board and re-plugged the board back in and the board still didn’t register on a COM port. The final steps I did was what was mentioned above which also included a re-boot of windows. I don’t recall if I tried to re-boot windows without uninstalling the drivers first.

Hi Mike
I seem to be having the same trouble as you, however I have tried everything and it is still showing up as “Meadow F7 Micro” in USB Devices after removing drivers and restarting.
Can you tell me what is should show up as? Is it in USB Devices or under legacy Hardware in Ports(COM&LPT) ?

Once it started working it showed up as “USB Serial Device (COM3)” under Ports (COM & LPT) in Device Manager. Yours may not be COM3.

Thanks mate. I tried it several times with no success. But did get it to work eventually. I think i may have installed a different driver with zadig. restarted. then installed the correct driver. restarted then it turned up. It may help someone else.

Hi! thank you Chainsoftwarejeff for your answer.
can u please tell me, what exact driver did you installed?
i cant start my Meadow from Windows 7 :frowning:
thank you

what’s the ‘correct’ driver?
Where did you get it?
Do tell

serversize6, all the details are here:

No its not
I’ve tried every driver I could find on the internet.
Why don’t you link to the one you know works?
Why do the instructions on the dev portal (which I’ve read about 100 times in desperation) start AFTER the problem I’m having. The instructions assume you already have the ST device driver successfully installed and showing up in device manager?
Is the correct driver a secret or something?

serverside, the link in my previous post is the link to the process that works. Using Zadig, you don’t have to download the driver because Zadig does it for you. It places the downloaded driver prior to installation in C:\Users<username>\usb_driver\ so you can confirm that the driver you selected is the one that will be installed.

It does not assume you have the driver installed already, but downloads, installs and links the selected USB driver for the Meadow. Then when you put the Meadow in Bootloader mode, Windows uses that driver to connect and assigns a COM port.

Using the WinUSB driver worked for me.

snympi,
thanks for taking the time to respond.
However, you’re missing the point.
In order use Zadig to map the WindUSB driver you have to get an ST device/driver available to map.
I cannot, for the life of me, get such a device to show up in DEVICE MGR.
My problem starts way before Zadig.
If you look at the docs they all talk about a device that is already showing up in device manager as a USB device.
You then fire up Zadig and map the WinUSB driver to it.
In Zadig I have nothing of interest to map FROM.
There is some driver that must be SUCCESSFULLY installed first, before you can even think about using Zadig.

I understand serverside. My experience was that as soon as I connected the Meadow I received the Windows notification that USB device was detected and Windows is setting it up. I did not have to install any USB drivers to make this happen. Then when you convert the Meadow to BootLoader mode, it is recognised as a different device (type) with a different USB driver (ST) that I also did not have to install before changing it to WinUSB using Zadig.

So I guess it will help if you can let us know what happens when you connect the Meadow, without setting up the BootLoader (any Windows notifications about setting up a new device), and if successful, do you get any additional message if you THEN convert to BootLoader mode.

snympi,
I just got enough community cred to reply to your last post.
Thank you so much for giving me the courage of a conviction that I had yet to find an adequate USB cable.
I had literally tried 6 or 7 different cables. When you said I should get the usual bings and popups associated with Windows detecting a new USB device detected.
I pulled a USB cable from a MIDI keyboard that works with my PC.
YAyyyy! I’m connected Now!
Thanks again.
P.S. Posted new help request for exception occurring on deployment/remote execution.

1 Like