Community

Ages to Download

I have just dug out my Meadow board having received my backers kit many months ago.
Followed the instructions to create the default Meadow App.
Selected deploy and then waited an hour and still the application had not downloaded and run however, it had downloaded meadow.dll, meadowfoundation.dll, mscorlib.dll etc. So I figured with the largest files downloaded if I restarted VS and tried the deploy again it should just download my app…wrong !

2>------ Deploy started: Project: FirstMeadowApp, Configuration: Debug Any CPU ------

2>[14/04/20 16:22:21] Deploying to Meadow on COM7…
2>[14/04/20 16:22:21] Initializing Meadow (00:00:00.0003297 since last.)
2>[14/04/20 16:22:27] Device (00:00:06.0745379 since last.)
2>[14/04/20 16:22:27] Checking files on device (may take several seconds) (00:00:00.0020972 since last.)
2>[14/04/20 16:22:57] Deploying for the first time may take several minutes. (00:00:30.0484094 since last.)
2>[14/04/20 16:22:57] Writing App.exe (00:00:00.0242906 since last.)
2>[14/04/20 16:26:17] Writing Meadow.dll (00:03:20.0171703 since last.)
2>[14/04/20 16:29:37] Writing Meadow.Foundation.dll (00:03:20.0522486 since last.)

I just don’t get this - am I going to have to wait many many minutes every time I need to deploy ?
I figured that it might just be that the latest Meadow OS was not installed on my board but when I click Download Meadow OS from the Meadow Device Explorer, nothing happens at all. Likewise, if I click Flash Device, nothing, no error message.

Anybody have any thoughts ?

Andy

Okay, looks like I was not pressing the boot button so it was not going into dfu mode.
It now seems to be working better :slight_smile:

Andy

I want to thank you for adding the solution that you found to your thread. I was experiencing exactly the same thing that you talked about in your first post when I tried to publish from my Dell laptop. Your additional post got me pushing a few more buttons, Thanks