Using ethernet on Netduino 3E


I am using the Netduino 3 Ethernet for a class, and am having some issues with the ethernet port. When I follow the code in the tutorial, it errors out, and never grabs an IP address. This is not just an issue with my board, but with everyone in the class that has the same board. We found that this has never been built out for the board, is this true? If so, shouldn’t Wilderness Labs provide a solution for this? We found that the 2 Plus works just fine.

That shouldn’t be the case. We have tested it and have it working. However, there is some timing issue with certain routers. We have a bug filed here on it, and it’s on our list of fixes we’re working on in the network stack.

Have you tried plugging the board into a different network with a different router? Can you tell us what router the board is connected to?

So I just tried it on my home network, and it works fine. So it has something to do with the university network. We will have to figure out a workaround, I guess.

Thank you for the quick response!

Let me know if you figure out what kind of router it’s hitting. Would love to get this fixed.

Is it a problem with organisational restrictions?

Some companies / organisations restrict connection to networks by only allowing machines with recognised MAC addresses onto their network.