Netdunio 3 wifi not recieving uart data

Hello folks, this is my first post, i don’t normally post things but prefer to just solve things on my own, but i am stuck. I have a 3.3v R232 to USB cable from adafruilt (i cant remember for sure) that i am using to communicate with my pc for test purposes (end result will be app running on raspberrypi mono with serial coms) but for now im just trying to get it to work with my PC. I can receive my bytes just fine to my pc at 115200 baud just fine, but when i send the bytes back my N3 doesnt even receive a event call. How ever if i unplug the RX pin the event will fire (with no data) but i am thinking its a voltage issue. I have tried handshakes/etc. Im using COM2 but the result is the same as on Com1. Serial.Timeout has no effect either.
When the pc TX pin is connected to the N3 RX pin should the voltage be high or low when idling? Batteries are dead on my voltmeter currently, but im just trying to get some hints. Any ideas? I couldnt get wifi to work so i abandoned that route hoping this would be easier, but i have to have 2 way coms for my project.
Thank you,

I am pretty sure that Serial / UART is high when idling.

One thing I have noticed is that when I send data from a PC .NET application using an FTDI cable to a microcontroller that the transmission is not instantaneous. Have you tried streaming a continuous series of bytes as a test? A continuous stream would fill any buffers and force them to be sent.

I will set up a test on COM2 and let you know what I find.


Thanks mark, ill try that tonight, what kind of timing in millis should i space the bytes? or just send a array of 100 or something every 50 milliseconds? Thanks again.