Community

Beta of Netduino 3 Wifi firmware version 4.3.2.4

Hi all,

We got some stability fixes for Netduino 3 Wifi firmware ready for beta use. Please download the updated firmware and use Netduino Deploy or Netduino Updater to update the firmware on the device.

Please let us know how it goes!

Brian

During the process, when running NetduinoDeploy-Win-2.0.3-beta (the device shows up fine), when clicking on Firmware->Choose, the updater crashes without any message. Therefore unable to update to this beta firmware version.

Any suggestions on how to update please?
Regards

You could try the old Windows updater. The download to that should be on the same web page as the new one.

Regards,
Mark

Hi Mark
Looks like since I upgraded the usb driver on my PC to have the Netduino work with the latest [Deploy], the updater [NetduinoUpdate] does not pick up the device anymore (or it sees the firmware version to be current and therefore ignore it).

Also, I can’t remember a menu function to load firmware from disk on the Windows version of [NetduinoUpdate]. I think its only the Mac version allowing that.

So, a message to the developer of [Deploy_Beta], is it possible to fix it? Otherwise, please send me your code so I can try to debug it. I notice it is done Xamarin Forms, which I know well.

Regards

The NetduinoUpdate application picks the latest version of the firmware for the board automatically. In order for it to do this you need to put the directory holding the firmware in the application directory. My directory structure looks something like the following:

Simply copy the new firmware in the Firmware directory and start the application. It should find the latest firmware when you plug in the board in DFU mode.

Regarding the beta version of the new deployment application, the developer working on this has been informed of the issue and will be looking at this soon.

If you are interested in the software then you could download the sources from the Netduino-Updater repository.

Hope this helps,
Mark

I finally managed to install the beta firmware by running the Deploy-Beta from within Visual Studio. Thanks for the link to the source code. It appears by simply giving us a copy of the bin folder is not enough to successfully run the app. Maybe Wilderness labs should rather [publish] it.

It is quite possible the SSL bug is now fixed with this Beta release of the firmware. I am now able to call the Azure IOT hub from Netduino using SSL (as it requires). I did not do a comprehensive test, that why I’m saying [quite possible].

Well done to the developers and thanks.