Community

Application Deploy Exception

Trying to deploy the template Meadow project app and got error. Log:
1>------ Deploy started: Project: MeadowApplication1, Configuration: Release Any CPU ------
1>[24.11.2020 1:05:02] Deploying to Meadow on COM4…
1>Exception of type ‘MeadowCLI.DeviceManagement.MeadowDeviceManagerException’ was thrown.
========== Build: 0 succeeded, 0 failed, 1 up-to-date, 0 skipped ==========
========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========

When trying to update Meadow.OS got error:
[24.11.2020 1:16:28] Begin ‘Flash Device’
[24.11.2020 1:16:28] Upload Meadow.OS.bin (~2 mins)
[24.11.2020 1:17:41] Initialize device (~30s)
[24.11.2020 1:17:48] An unexpected error occurred. Please try again.

any suggestions?

I get the same error when deploying various sample projects.
I was able to deploy the HelloMeadow sample project successfully without error.
I then tried to deploy the Simon project and received the error below.
Now when I go back and try to deploy the HelloMeadow sample project, I continue to get the MeadowDeviceManagerException error, though the app is deployed and runs successfully.
Tried re-flashing the Meado.OS… didn’t help.

=======================
Deploying to Meadow …
Initializing Meadow
Checking files on device (may take several seconds)
Found Meadow.Foundation.dll
Found App.exe
Found mscorlib.dll
Found Meadow.dll
Found System.dll
Found Mono.Security.dll
Found System.Configuration.dll
Found System.Xml.dll
Found System.Security.dll
Found System.Core.dll
Found System.Numerics.dll
Error: Exception of type ‘MeadowCLI.DeviceManagement.MeadowDeviceManagerException’ was thrown.